2

For the last couple of weeks, I've had the weird rainbow header on AskDifferent, as seen in Why do I occasionally get a big rainbow in the top banner?

This is what it looks like:

Rainbow Header

The Meta site does not show a header at all, it's just blank:

Meta Site without header

This is on Chrome 59.0.3071.115 on macOS 10.12.5. Other browsers (Safari) on the same machine work fine. Here's what I tried to fix this:

  • Refresh the page with a hard reload/clear browser cache)
  • Logged out and in again - not easy since the log out/in links are not visible without the header
  • Tried to load the page on different networks (home/work)

None of these have helped.

Other StackOverflow sites work fine. When loading the page, the header is visible for a second or two, then it's covered by the rainbow header or the empty header on Meta.

The issues is making AskDifferent pretty much unusable for me at the moment (at least from my default browser). Any idea what could be causing this?

3

Found the answer after a couple of minutes...

This issue was caused by the following TamperMonkey script: https://github.com/shu8/Stack-Overflow-Optional-Features

Disabling this in TamperMonkey made the site work again. The version in question is 1.8DEV, which seems to be the latest version.

I've disabled this script now and everything is working again.

  • I’ve started seeing this a lot on content blockers on mobile safari as well and testing 10.13 and iOS 11 browsers. Perhaps the JavaScript is being blocked - either intentionally by Apple in the new features to prevent cookies from domains that do not get visited explicitly and/or by content blocking rules. – bmike Aug 24 '17 at 17:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .