10

iPhone SE (first generation), iOS 14.4.2 (18D70), iOS Safari

I have regularly used this phone to browse the SE sites in which I'm interested: Travel, Expatriates, Mechanics, Home Improvement, and Ask Different. The phone's now running 14.4.2; over the past months I've updated it promptly as new versions are offered. Keychain takes care of my passwords, and all seemed good.

Today, however, when I navigate to any of these SE sites, I'm confronted with this:

enter image description here

Nothing has changed in the phone's settings, cookies are not blocked. Under the dialog, I am already logged in. Even odder, when I click on "Customize settings" there's a brief rotating wheel symbol, followed by...nothing: the dialog remains in place, blocking the page. I can only get rid of the dialog by clicking "Accept all cookies." The same thing happens on all five SE sites. It isn't happening on my desktop machine.

Restarting (both regular and forced) has no effect, the dialog keeps appearing. And the dialog is persistent — it appears every time the phone loads an SE site.

What's going on here?

8
  • 3
    I don't believe that this is isolated to iPhones or Safari since I have seen this on Chrome on my MacBook Pro.
    – agarza
    Apr 3 at 3:08
  • @agarza Currently? In the past? Same behavior? Apr 3 at 3:19
  • 1
    Yes, within the past week with the same notification.
    – agarza
    Apr 3 at 3:34
  • 5
    It appears people have different experiences based on privacy settings and so versions and content blockers. For me, this is on iPhone safari and macOS safari and not iPadOS safari. But since it’s happening on many accounts (mine included) on multiple SE sites. and this and [that(meta.stackoverflow.com/q/406344/475228)
    – bmike Mod
    Apr 3 at 3:40
  • 3
    This has more to do with SE than with Apple products so the Meta site might be more appropriate.
    – nohillside Mod
    Apr 3 at 7:40
  • @bmike yes it does occur on iPadOS Safari - well at least on mine - note I do have an adblocker on
    – mmmmmm
    Apr 3 at 10:05
  • 2
    Thank you for reporting. This is part of a series of related bugs that the team is currently looking into.
    – Rosie StaffMod
    Apr 7 at 13:36
  • 2
    Okay after tearing our hair out testing across multiple versions and not reproducing any fails, we finally understand the issue. Safari specifically likes to remove all JavaScript cookies (even first party) after 7 days. Sooooooo, that's fun. But we can do some things here. It seems to respect HTTP-issue cookie durations appropriately, so on dismissal we're going to try making a server-side call purely for setting the cookie in a way that'll stick for Safari users. I'll talk with Samo Monday and you should expect us to try this early next week. We'll drop an answer here when it's in place. Apr 23 at 17:26
0

This appears to be related to changes SE has made network wide on settings they expect us to change or adapt our browsers to accommodate.

The text in that question asks for feedback and has a bunch of suggestions and changes as the feature was tested, so we might need a more focused answer here based on what to do today as opposed to the three months this was put into production here on Ask Different. (FWIW, I missed all the notices sent on this and didn’t realize till this question was asked that I needed to take action. It is also satisfying to just stop using the site when it pops up a window obscuring the content.)

The accept all cookies path wasn’t working for me, clearly. Neither is the customize cookies. Both buttons, when selected don’t function to dismiss the dialog for me on my Mac or iPhone whereas my iPad somehow got past this annoyance. I have no idea how my devices got this way, I intended to have all three function exactly the same. I have reviewed the settings and can’t see something I set differently on them.

5
  • 1
    I tried it on my iPhone 11 (iOS 14.4.2) and I did get the dialog from customize settings. It popped right up. Previously I have just clicked on accept all cookies on my Mac and work PC Apr 3 at 13:36
  • I wonder f the code or backend database is changing under our feet @SteveChambers
    – bmike Mod
    Apr 3 at 13:38
  • Possibly, I've never used the customize settings button before this. Also maybe this question ought to move to Meta? Apr 3 at 13:39
  • 1
    There are dozens of threads already on meta - meta.stackexchange.com/a/362864/165931 included @SteveChambers ve linked back to here so the threads are easy(er) to follow
    – bmike Mod
    Apr 3 at 13:43
  • Unless using an ad blocker, this should be working. We've also fixed the case (we think!) of ad blockers specifically. The intent is absolutely not to annoy you - it's to be legally compliant and be as seamless as possible. Ad blockers threw some curve balls here - in those cases we are trying our best to handle it the same as clicking no (because the ad blocker is preventing consent code from functioning). Mobile Safari is another issue...which I'll leave a comment on above shortly. Apr 23 at 17:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .