4

I just wanted to go to the blog in order to leave a comment.

However, it really took me a while just to get there! I simply could not find a link.

How come the blog is so hardly accessible? What can we do about this?

I vote for creating a placeholder at the top - next to review, chat, meta, about and faq.

enter image description here

  • For some reason, I could not add the tag 'blog'. So I had to use 'discussion' instead because I could not post without a tag. I was also asked several times to verify that I'm a human being when trying to post this?! Lol. – gentmatt Jan 5 '12 at 7:38
  • +1 agree with it being alongside, review, meta, etc, etc – Graeme Hutchison Jan 5 '12 at 10:55
2

I will note that in the current implementation, a 'blog' link is added to the header navigation with a 'NEW' stamp next to it for 24 hours following a new post on the Ask Different blog. But after that 24 hours? Poof. Back to only the footer.

Note: Per Rebecca Chernoff's comment, blog links on the main site go to the Ask Different blog where blog links on the meta site go to the Stack Exchange blog.

  • Ah, I thought that I've seen a placeholder before. Then I assumed it was a false memory. In your last sentence you indirectly mention that there is a permanent placeholder for the main Stack Exchange blog?! I don't see one. – gentmatt Jan 5 '12 at 8:08
  • You pointed it out in your question :). Above the list of graduated sites in the footer. – Jason Salaz Jan 5 '12 at 10:06
  • I didn't see you wrote footer.... Still, I'm confused: There are two blogs? I only find this one. – gentmatt Jan 5 '12 at 10:21
  • 1
    Your link goes to the Ask Different Blog on BlogOverflow. The footer blog link always goes to the Stack Exchange blog. I'll note that the header blog link switches between AD and SE, whichever one was posted in most recently, I think. As an aside, the podcast link always goes to the Stack Exchange podcast, there is no link love in the site's navigation for the Ask Different Podcast. – Jason Salaz Jan 5 '12 at 10:43
  • This isn't entirely correct. Both links on the main site (the header and the footer) go to the community-specific blog. Both links on the meta site go to the SE blog. – Rebecca Chernoff Jan 6 '12 at 18:19
  • Well that's confusing. And did it change at any point? I could swear at one point after apple.blogoverflow existed that I've gone to blog.se from the Main site, but indeed there in no 'NEW' tag nor even a blog link in the header at the moment despite a new blog.se post. – Jason Salaz Jan 6 '12 at 19:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .